edited January 11 in ORK Support
I have many events that play background sound ("horror whispers") under the main voiceover sound. Is it possible to somehow fade out the long background sound in the Event system? (ORK 2.34.0).


More info
Since every of these "voiceover" events takes different time (depending on the length of the voiceover wav), I don't know how long it will take. So the underlaying "horror whispers" sound can play 5 seconds or 20 seconds or whole minute, depending on each event. So I can't make the fade out part of the wav itself, I have to use long looped sound. Right now, the sound is just sharply stopped when the event ends and this doesn't sound good. I would like to somehow fadeout the "horror whispers" right before the event ends.

Thanks :-)
Post edited by tlamiczka on
  • I'd recommend using multiple sound channels for this - or if you play sounds via music, using music channels.

    That allows you to fade the volume for a channel. You can play sounds on a sould channel either via the Play Sound (Channel) node or by linking an Audio Source on a game object to a channel using a Sound Channel component.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 11
    Cool this seems to work nicely :-) I'll let one of the channels reserved for this type of sounds.

    image

    Thank you.

    p.s. only one sidenote - when I set the volume of the Play sound for example to 0.3 and then use fade out in Change Sound Volume, the fade goes from full volume 1, not from 0.3.
    Post edited by tlamiczka on
  • Yeah ... it plays the sound at 0.3 volume, but the sound channels volume isn't changed by that. You should probably first set the channel's volume and play the clip at volume 1.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I thought so :-). So I'll leave the volume of the sound itself to 1 and will manipulate only the volume of the dedicated channel.

    So I added new "Change Sound Volume" event at the start and changed the channel's volume to 0.3 before playing the sound itself. And it works as intended now - no annoying spike at the fade out, it now goes from 0.3 to 0 at the fadeout :-)

    Thanks :-)
  • I'm redoing the game from ORK 2 to the splendid ORK 3 and I came to a weird problem - I set up the schematic in Makinom exactly like the event in ORK 2 but it seems the trick with changing of channel's volume doesn't work as before. Or more exactly - it seems the volume of the channel doesn't change if I use the "Fade" option. (but options Mute and Set work correctly).
    Could it be a bug or am I doing something wrong and the setup have to be different in Makinom?
    See updated schematic:
    image
  • edited March 24
    I'll check it out.

    Edit: Yep, will be fixed in the next update :)
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited May 21
    Hello @gamingislove was this fixed in ORK 3.3.1?
    Post edited by RustedGames on
  • No, was already fixed in ORK 3.3.0 (or rather Makinom 2.4.0) :D
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.