I've set up footstepper and everything is working fine. But if I am walking or running and then do an attack, the footsteps sounds keep playing for 2 seconds or so. I am using animation events for the footstep sound in the walk and run animations. I would like to stop the footstep sounds when attacking.

Is there any option I can use? I've looked in the documentation but I can't find anything.

Thank you!
  • That's probably due to animation blending still having movement animations playing, causing footsteps.

    You can try different Min Animation Weight values to find a good one that prevents the footsteps from playing in those cases.

    Alternatively, you could disable the Footstepper component or change it's Mode during the attack animation to prevent footsteps.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Thank you! I've fixed it! :D
Sign In or Register to comment.