I recently updated one of my scenes by importing an updated asset package that included the scene. When I added in my battle and grid-map prefabs and tried to play the battle, which is started via trigger enter, won't play. I've tried other start by setting such as via interaction or trigger exit, and even rebuilt the battle via adding a new battle with the Ork Scene Wizard Create Object and set it's settings to what's in the prefab, and the battle still won't start. As far as I can tell the battle start event doesn't seem to be even triggering in the first place since it's Debug's don't come up in the console. Anyone have any ideas of something that could influence that? Other colliders do work, including scene changers and talking to NPC. Just not the battle start.
  • edited October 2
    Do you get any errors or warnings in the Unity console?

    When testing, do you test this by starting directly in the scene? Since you basically replaced the scene, you'll also have to add a game starter that directly starts the game in that case.

    Generally, when a battle isn't starting, it could e.g. be:
    - no enemy to fight (e.g. wrong faction selected, or enemies start dead due to 0 health, etc.)
    - player is dead
    - scene ID already set (i.e. fight already done) or other conditions set up in the battle not valid
    - player controls blocked
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I'm not getting any errors or warnings in the Unity console.

    When testing I load into a different scene first and then use a scene changer to get into the new scene. I know I have to replace all the normal parts of it: add the scene changer, the battle, the waypoint for spawning relevant prefabs (including the grid), and NPC dialogue that sets up which battle I'm going for (and therefore which of the battles enemy groups are used via a game variable, as well as spawning the grid for the right battle before the battle starts.) But most that appears to be working.

    - All of the enemy groups are set to the enemy faction and their HP calculations are the same as they were before the load in so that should still work.
    - Player is not dead.
    - Battle is set to "Use Scene ID" disabled.
    - Player controls appear to be working fine, but turned "In Blocked Control" to enabled on the battle just to be sure and the battle still does not start.
  • Try using the start type Autostart (e.g. with a 1 second delay). If that works, it's most likely a physics thing not working.

    E.g. no rigidbody component involved, the layers are set to not collide with each other, etc.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • The Autostart setting did not work.
  • Huh .... are battles working in a different scene?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I've tried them in a few scenes and they do not appear to work in any of them anymore. I guess maybe the import might have caused data corruption and I should try updating ORK to see if it repairs it. I'll let you know if that works.
  • Alright. I updated ORK and made sure it's install was fine and that didn't change the scenario: the battles are still not starting in any scene whether via auto-start or trigger enter, with battle groups that have requirements or with no requirements.
  • If no battles are starting, check things like faction sympathies (factions used for the enemy have to have negative sympathy), battle ranges, etc.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited October 12
    All of those things were previously working, but I've rechecked faction sympathies and battle ranges and they were fine. Also, are there any particular layers that things need to be on from the ork side of things? Currently the grid's layer mask is set to the "ground" layer I use for the terrain. And the collider for the battle (and therefore it's collider) is set to "Ignore Raycast" while the player combatant is on "Combatant". Is that a problem? Does it need an "Ignore Raycast" layered collider?
    Post edited by Whatexists on
  • Layers can play a role in different things, but if the battle isn't even starting with different start types (e.g. checked via a debug output in the battle start event), there is most likely a different issue.

    Think you can send me a small Unity test project where it happens?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Sent you the project. Hope it all works. Let me know if you find anything!
  • Answered your email - for others that might run into such an issue:

    Using a combined status value for your max HP and having enemies with max HP 0 (since the combined value will generate it) will lead to dead enemies, so no battle happens. This'll be fixed in the next ORK update - for now just set a max HP for those enemies that is greater than 0.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Yeah. That solved the problem! Thank you!
Sign In or Register to comment.