edited September 2020 in ORK Support
I had a system shutdown while working in unity and after reboot the entirety of my Ork events are not recognized anymore and impossible to be used as before. If i create a new event it works, but all my other previously created events seems to be unrecognized anymore.
Unity consoles says this about those files: Unknown error occurred while loading "x.asset".

I tried uninstalling ad reinstalling Ork, deleting and rebuilding library folder. Importing those files in a whole new project.
But still no luck. Have i lost them forever?

Update: I tried opening the event files with notepad and insides there are only blank space characters. I gess they really are corrupted.
Post edited by Vlastan on
  • Yeah, sounds like they're corrupted - though it's a bit strange that this'd happen to all your events. ORK itself would only write on the event files when you actively save in the event editor (or when saving your ORK project in the editor after making changes that need to update events).

    If your event assets have a very small file size (e.g. 1kb or less), they probably lost their data.
    I can check out some of your events if you send them to me to see if I can open/salvage them (send them to contact@orkframework.com), meaybe also include your ORK project asset.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Indeed it's strange that they all got damaged at the same time.
    Anyways i sent you the files. The file sizes for each one is more than 1kb, so they seem to still contain data. I hope that something could be done.
Sign In or Register to comment.