edited November 2019 in ORK Support
I set up my character using the tutorial below:
http://orkframework.com/tutorial/gameplay/mecanim-animations/
and this other link:
http://forum.orkframework.com/discussion/comment/30274

Character movement it works perfectly. Some animations in battle work very well too, like "Damage", "Evade", "Victory".

I set a mecanim animation for all States in the Ork framework, but in the battle, when I attack, cast a spell or use an item. None of these actions plays the animation. How I could make them work?
Post edited by claudiomg on
  • Have you set up battle animations / battle events for them?
    For abilities and stuff you should just call the mecanim animation from the event itself
    Shadowcaste
  • As @Wrofir said, for your attack or a spell to be animated, you need to set that up in a battle event that's used by the ability or item. Only certain animations are automatically called by ORK (e.g. damage and evasion, or idle/movement animations when using auto animations on your combatant), the rest is up to you to animate.

    The game tutorials go through all of that, so I'd highly recommend to do them if you haven't yet :)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I go through the game tutorials and didn't find one specific that tells how to animate a character using a mecanim animation on a battle event.

    I try to use the cast event and set the Cast animation just like the image below:
    image

    I set up the Cast animation on Base/Controls -> Animation -> Default Mecanim, see the image below:
    image

    But still didn't work, what else I need to do to make this work?
  • Can you post a screenshot of your animation controller for that character?
    Shadowcaste
  • Yes, here it is:

    image
  • Instead of combatant animation try "Mecanim animation" and call "Cast" in it, make sure to add a wait afterwards equal to how long the animation is.
    Shadowcaste
  • What's happening before the animation is called by the event? E.g. if the combatant was previously moving, the animator might currently be in transition to the idle animation. Try adding a Wait node (e.g. 0.1 second wait) before the Combatant Animation node.

    If your cast animation is played by the cast parameter in your animator controller, try setting up the parameter in ORK's animation setup.

    Also, make sure the used combatant's animation System Type is set to Mecanim and uses the correct animation setup (both found at the bottom of the combatant's settings).
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I add a wait node before the Combatant animation Node and it works. Thank you so much @gamingislove and @Wrofir
Sign In or Register to comment.