edited September 7 in ORK Support
Hey guys, so I'm having this weird issue and never seen anything like it before. This is all 2D by the way, I have my player set up and I have his walking animation set up also. Now, usually, everything works fine. I hit New Game in the menu, player spawns, and then he walks fine. But occasionally (not sure what triggers this, seems to be random as I've tried different things, like pressing arrow buttons between scene load, doesn't seem to matter, and this happens about half of the time I start a new game) occasionally as my character walks the walking animation will start playing super fast, so fast that I can't tell if it's just flipping between two frames or cycling through the entire animation at a high speed. This happens with my very first movements of after starting a new game, about half of the time.

What's weird is that as soon as I click anything, whether that's trying to click on my player in the scene hierarchy, or to click down on the animator window, or even just on the game screen itself -- the problem seems to be corrected. Indeed, it seems to be solved by a simple click. Normally I would try to look at my Game Object and then my animator and see exactly what's happening but I can't do that without the problem being corrected.

Now, I realize you may need more information from me, such as how my game is set up, but perhaps this is a common bug or something that someone has had a problem with as well. I haven't done much yet, really. I haven't added any of my own scripts, either. I just set up my animations entirely through ORK's framework and using the default top-down controls and recommended 2D settings. I only have one scene so far and player control is blocked on scene change.

Also -- this bug does persist even in the built version of the game (though the click then doesn't seem to fix it). If you need any more info please what me know what specifically to bring and I will do so in my reply! Thank you very much for taking the time to read this and to help me!
Post edited by fatbastard on
  • edited September 7
    If only the animation is playing fast, I'd assume it's due to either the animator speed or the individual state/animation speed being set like that from something.

    Do you use ORK's animation functionality to set the animator speed?
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited September 7
    No sir, I am not setting the animator speed through ORK. It's set at 1 while moving through mecanim, and 0 while not moving. I just now tried setting it to 1 through ORK but it did not help. I have brought screenshots of some of the animation settings within ORK.

    image
    As you can see here I don't have any of the speed set through this part. I have four different mecanim which are set through bools from the animator controller. In ORK, I have it set to flip the other 3 bools off when the one is turned on which I will highlight in the next photo.

    image
    This is the general way I have the bools set up to work, it continues on this way for the rest of the walking directions.

    image
    Here is a screenshot of the animation settings under Combatants.

    I would also like to highlight 2 things.
    1.) After further observation, I believe that in the bug it's not only playing faster, but that it's not playing the full animation. It's flipping between only two sprites/frames in the animation.

    2.) I would like to reiterate, because I think it must be important -- when I click on my player gameobject in the hierarchy, the problem vanishes and my animation is playing perfectly.

    Thank you for the help sir, please let me know if you require any additional information.
    Post edited by fatbastard on
  • I believe I've solved the problem. It's been good for about 10-20 tests now. I think it was because I didn't have "find the ground" detection set up under the combatant settings. I will let you know if that changes.
  • Hm, not using ground detection shouldn't be an issue, as the combatant would be considered as always on ground. Though if you're also using jump/fall animations (e.g. in the Button player control), that might cause issues.

    Also, beside the combatant's ground settings, there's also the default setup in Battle System > Battle Settings > Combatant Settings for all combatants.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.