I have been having some trouble with making zoom and pan work properly in my game. The game is a 2d top down game on the XY axis. Panning works fine horizontally but does nothing on the vertical axis.

Zooming doesnt really do anything , just like changing height and distance doesnt really do anything on the camera control itself.

In the inspector the camera always defaults to a bigger size at runtime.

What i try to achieve: Just make the camera zoom in more by default, and adding working zoom/pan in certain situations

Any idea what i might be doing wrong?

Thanks in advance! Been almost half a year without problems but decided to replace my custom camera with the top down border one.
  • Are you already on the latest version (ORK 2.31.0)? There've been some changes and fixes for 2D (XY plane) for the top down camera.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • yes i updated it yesterday, i was on 2.29 before that.

  • Checked it out, seems there's an issue with vertical panning in XY mode - will be fixed in the next update.

    As for zooming, that's working fine here. Keep in mind that zooming doesn't change anything if your camera is in Orthographic mode. While the camera get's physically closer/farther, the orthographic mode will still display the same.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited March 1
    I did some more testing and the zoom only does not work when using buttons instead of axis.

    When enabling the axis it does work. But i want to use buttons sadly

    And thanks for looking into panning! Excited for the next release
    Post edited by dendiee on
  • edited March 2
    Hm, zooming works fine with both axis and individual keys for me - what's the setup of the used input keys?
    Also, make sure that there are different min/max height/distance settings, otherwise there's no room for zooming available :)
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Ill post some pictures showing the current setup that might help give an insight.

    https://imgur.com/a/HKlfywC

    The custom input origins (using rewired) do work correctly. Even when selecting a button that is usually working (for example the interact button) it does not zoom in.

    When changing to "use axis" in the zoom setting, and not touching any of the other zoom settings, it does work.

    Am i forgetting something in the zoom settings?
  • Ah, I see - you also need to set up the Custom Axis Function here to be able to get axis input information. While being individual input keys, they still use axis input here instead of just pressed/not pressed to allow slower input zooming (e.g. from triggers).
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Aha, great!
    Ill look into this, thanks!
Sign In or Register to comment.