edited January 9 in General Support
1. I can indeed switch the control role by pressing Plus Key or Minus Key, but only one of the original two roles is displayed.

2. The second character will initially appear in the air after the scene is changed.


3. The camera position will occasionally shift. For example, after battle or after switching roles.
Post edited by who2345 on
  • 1) If you have Only Battle Group enabled, the group member keys will only switch between members of the battle group.

    2) Try adding a Place On Ground component to your combatant prefabs. Also make sure the Spawn Offset of your combatant's prefab settings are set correctly.

    3) Might be a short camera control block or use of a camera position/change, e.g. in death events of the combatants.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • 1) According to the setting,'Only Battle Group enabled' does not work, there is still a problem.


    2) Success, thank you!

    3) I used the OOTII camera according to the tutorial, and adjusted the distance farther, but the lens still shifted or the distance became farther or closer during battle.
  • 1) What are your Group Spawn Settings in Game > Game Settings > Player/Group Settings?
    Also, I'd recommend to use a different movement component in the move AI, e.g. using Unity's NavMesh.

    3) It looks like you're using a camera position or change the camera's game object in events or the battle camera (Battle System > Battle Camera). Based on the video I'd say it's most likely in death events of the enemies.
    Also make sure the Reset Camera and Reset Look Angle settings in the event settings (e.g. of the death battle events) are not enabled.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 11
    1) This is my setting, please find out where the problem is!
    https://photos.google.com/photo/AF1QipN_gBX9d8BNXuVBX5lCNUnu2fekgOGNBFy-6x0l
    https://photos.google.com/photo/AF1QipN0-mrIjIe7Wiexp3AYaZmU5R4XJUqxGApBvxB1
    In addition, thank you for suggesting me to use other move AI software, I will look for it.

    3) Thank you for telling me to set the camera position. I changed it to the following and the problem was solved.
    https://photos.google.com/photo/AF1QipM9jzq827i2h2Y1dfbKhnB4xIbIe-XTeNwpY2Ur
    Post edited by who2345 on
  • I can't see any of the photos, could you post the correct links?
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • do it again

    1) This is my setting, please find out where the problem is!
    https://flic.kr/p/2krxznE
    https://flic.kr/p/2krxzow
    In addition, thank you for suggesting me to use other move AI software, I will look for it.

    3) Thank you for telling me to set the camera position. I changed it to the following and the problem was solved.
    https://flic.kr/p/2kry2Vf
  • edited January 12
    1) Hm, I've tested it with the same setup and it works fine here.
    Both combatants are part of the player's battle group?

    It might be the easier if I can check out a small Unity test project. If you can prepare a small project (just remove what's not needed, and also delete the Library folder in the project's folder) and send me a download link to contact@orkframework.com I can check it out.
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited January 13
    For others having this issue - it's due to the interaction controller setup.

    If you use Add Automatically in Base/Control > Game Controls > Interaction Settings ORK will add the interaction controller and also destroy it when switching the player. However, if you also add the interaction controller to the root of your player's prefab, it'll not add it and use the added one, but still destroy it when switching the player, leading to destroying the whole combatant.

    So, either use Add Automatically or have the interaction controller added to prefabs, not both :)
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Thank you, thank you very much, and finally solved the biggest problem. After all, this problem is related to the game method~ Next I will start to study how to use Move AI, such as using Unity's NavMesh, otherwise the characters will circle each other~ Thank you Help~
Sign In or Register to comment.