edited August 1 in ORK Support
In Unity 2019.4.4 I installed Makinom and ORK, with Plugin. What is the proper game-starter set up, both in the Main Menu and in a scene to test while avoiding the main menu? Do I need both, or just one? Should I change any settings (e.g. untick "start game" in one of the starters? etc.) I'm getting an error about not having a Makinom Project selected, but the default Project is in the starter. Here is a screenshot:
https://imgur.com/a/W8opYHX

When I exit play mode after getting this error (when trying to launch a scene that is not the main menu), Unity tells me I have unsaved data in the scene (the asterisk appears) even though the scene was saved prior to entering play mode. Any ideas?
Post edited by type4101 on
  • edited July 30
    You need a game starter for both ORK and Makinom, as they're used to initialize the whole data you've set up.

    For ORK, you'll use the usual setup, i.e. in your main menu scene without using Start Game, but calling the main menu (or do that in the main menu settings). In other scenes, use the start game setup for a quick start in that scene.

    For Makinom, I'd recommend just using the start game setup.

    As for the error - did you actually save Makinom at some point or is that just the default project that's crreated when you open the Makinom editor?
    Post edited by gamingislove on
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • I did save Makinom and ORK data. I haven't added anything else to Makinom yet. When I go through the main menu, I get no error, but do when I start the same test scene directly. Here are expanded screenshots of the error logs. When I highlight the first error, it flashes the ORK Game starter, and the second error indicates the Makinom Game starter. Here are screenshots of the problem in greater detail:

    https://imgur.com/a/7DCE0O4

    I also included the plugin settings, in case that helps.
  • It is probably not related, but I noticed that the Makinom and ORK scene wizard shortcuts are both "CTRL+ALT+W" which is a conflict.
  • I went back to fiddle some more with the problem scene, and found that when I delete or deactivate my player's spawn point (i.e. don't spawn the player combatant), there is no error.
    Here are the screenshots for the spawn point, schematic, and run-time player info:
    https://imgur.com/a/4B4hTrb
  • Yeah, it might be a timing issue, ORK being initialized and spawning the player before Makinom had a chance to do so.

    Try adding a Wait node (even with a 0 second wait) at the start of your start event.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • The zero second wait node removed the error. Thanks!
Sign In or Register to comment.