After doing that I got a weird error.... cause now my Ok buttons doesnt work.... nothing happens when I click on them :( So I can't even close the first window that always comes up when I start a new game.

What could cause this?

Also can I use a image instead of text for my ok/cancel buttons?

Thanks in advance!
  • Also my actionbar now comes in back of the actionbar graphics which it didn't do earlier. How can I get it up front?

    The Healthglobes and actionbar graphics is custommade UGUI graphics... One has sort order 0 and the other sort order 1.

    I have tried to set the actionbar gui box to layer 2 which I have created, but no difference since the actionbar still comes behind the other graphics.
  • And the menu that I call with Esc button just blinks and looks not correct and then the only thing I see after that is the close button only.

    But those menus that I have set a direct key to call is working.. ie Equipment, Abilities etc. It's just the overview menu that borks out.

    Damn so many weird stuff coming after just selecting the New UI instead of Legacy and setting the correct prefabs.

  • edited September 2015
    Ok now I got the actionbar to come infront by setting the other canvases sort order to -1 and -2 since I assumed Ork has sort order 0 and there are no option to change that.

    However just as with my ok and close buttons I don't get any reaction..... Lol now I noticed that the mouse isn't functional at all on the menus! It's just showing the menu but no mouseclicks works at all and no mouseover, no tools tips.... Neither does the key 1 button work to activate my default attack.


    I think I gonna need to wait until I get a response regarding this...

    EDIT** The main menu is working as it should though.... worth to mention is that I am not using the custom UGUI canvases there. So I tried to disable the two custom canvases... but no difference.
    Post edited by thrilled on
  • Looked through the console messages too... no red ones but a yellow one:

    Multiple EventSystems in scene... this is not supported
  • That yellow message doesn't seem to impact though... since when I add a canvas manually to my main menu scene then I get that warning as wel but the menu is still working.
  • And swapping back to legacy then everything is as it used to be....

    Still I want to progress over to New UI or UGUI which is more common to say I guess.
  • You know that you can edit your posts? :D

    The console message you received already tells what's going on - you already have an event system in your scene, i.e. ORK's event system for it's own canvas isn't used, most likely being the reason why the clicks don't work.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Ofc I know I can edit the posts and so I did, but I hate long walls of text and like when I break it down.

    Well a event system in my scene really doesn't help... since I have no idea what would be interfering with the canvas..

    I mean there are two things the has something to do with the canvas...

    1.) My own healthglobes (which I tried to deactivate)
    2.) The minimap (which I have not yet tried to activate)

    Beside this I have no clue what kind of event system that would be?
  • ugui creates a new object called event system in the hierarchy which if you search for event it should pop up. i had a similar issue with my own inventory i built when transferring it to another project but mine was reversed to where i had no event system and it cause my inventory to not work. couldnt click on stuff and my drag and drop broke, tool tips ect... which would do the same here if to many are in the scene the internals still worked so for things that are not using IPointerDown and IDragHandlers ect you wouldnt need to worry about deleting the one already in the scene . these helpers use using UnityEngine.UI;
    using UnityEngine.EventSystems; so if you dont see these at the top of your scripts go ahead and delete the event system. an just use the one ork spawns.
    new website can be found here http://www.fore-loregames.com

    Follow the game Development on Twitter https://twitter.com/Fore_Lore_Games

    or check out the face book page here https://www.facebook.com/ForeLoreGames
  • Well I can now confirm that there are no Event System beside ork's in my project... Also I don't have that error anymore...

    However the issue is still there :( I had wtyson to look through my scene just to verify that I wasn't missing something and he couldn't find anything either.

    What could cause it then? basically it's like some invisible layer is covering the visible ui and action bar
  • I'll need a Unity test project to check it out ...
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.